Hoppa till innehåll
Avathar

Serverunderhåll v.49

Rekommenderade inlägg

Vi kommer under den här veckan (vecka 49) att arbeta med servern för att byta från Apache som webbserver till Nginx då det längre inte finns någon anledning att fortsätta med apache.

 

Det kan alltså hända att forumet inte är nåbart men detta kommer aldrig hända under en längre tid.

 

Andra problem som att bilder inte visas korrekt och att formateringen på sidan inte är helt ok kan också uppstå.

 

Kontakta mig via avathar [at] anime.se om ni undrar över något.

Dela detta inlägg


Länk till inlägg
Dela på andra sajter

Blev klar lite snabbare än vad jag trodde...fick hacka lite men nu körs siten på Nginx. Om ni ser saker som att bilder inte visas och liknande så posta i den här tråden med URL till bild eller liknande som ger 404 så fixar jag det.

Dela detta inlägg


Länk till inlägg
Dela på andra sajter

Alla bilder från anime.se/bilder syns inte samt den sidan är inte heller tillgänglig

 

Hmmm, visste inte ens att den fanns :/

Dela detta inlägg


Länk till inlägg
Dela på andra sajter

Problemet är att inställningarna inte tillåter åtkomst av några filer annat än under /forum/.

 

Ska inte tillåta något annat än definerade sources för filer.

 

location / {
  index index.php;
   try_files $uri $uri/ /index.php?$uri&$args;
   rewrite ^(?!(/forum/uploads/))(?!(/forum/public/))(?!(/bilder/)) /index.php? last;
}
location /forum {
   try_files $uri $uri/ /forum/index.php;
   rewrite ^(?!(/forum/uploads/))(?!(/forum/public/))(?!(/bilder/)) /forum/index.php? last;
}

 

Så har jag det i nginx configen just nu tills jag har ett bättre sätt för det.

Dela detta inlägg


Länk till inlägg
Dela på andra sajter

Hmmm, avatarer ska inte ha blivit påverkade såvida inte någon hade missat att göra en avatar konvertering från 2.x till 3.x

Dela detta inlägg


Länk till inlägg
Dela på andra sajter

Hm, avatarerna finns kvar på servern, så det ska nog ordna sig... om vi bara kan klura ut varför sökvägarna ändrats.

Dela detta inlägg


Länk till inlägg
Dela på andra sajter

Hm, avatarerna finns kvar på servern, så det ska nog ordna sig... om vi bara kan klura ut varför sökvägarna ändrats.

 

Misstänker att en migreringspunkt har missats men att jag har kört den medans jag körde maintenance och benchmarkade apache installationen för att jämföra. Scriptet har då kopierat in dom avatarers sökvägar och pekat mot den gamla mappen eller liknande.

 

Vet att jag hade en varning som jag klickade på utan att tänka :)

Dela detta inlägg


Länk till inlägg
Dela på andra sajter

Skapa ett konto eller logga in för att kommentera

Du måste vara medlem för att lämna en kommentar

Skapa ett konto

Registrera dig för ett nytt konto i vårt community. Det är enkelt!

Registrera ett nytt konto

Logga in

Har du redan ett konto? Logga in här.

Logga in nu

×